IDfy - PHL UMID SSS Verification performance is degraded – Incident details
Report an issue
Get updates
Email
Slack
Google Chat
Webhook
API
Report an issue
Get updates
Experiencing partial outage
PHL UMID SSS Verification performance is degraded
Resolved
Major outage
Started 12 months ago
Lasted about 13 hours
Affected
PHL UMID SSS Verification
Partial outage from 10:50 PM to 12:50 AM, Major outage from 12:50 AM to 11:20 AM
Updates
Resolved
April 11, 2025 at 11:20 AM
Resolved
April 11, 2025 at 11:20 AM
This issue has been resolved.
Identified
April 11, 2025 at 12:50 AM
Identified
April 11, 2025 at 12:50 AM
This issue has been identified.
Investigating
April 10, 2025 at 10:50 PM
Investigating
April 10, 2025 at 10:50 PM
We're currently investigating this issue.